You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

51 lines
971 B
Nix

let
nixpkgsOptions = {};
pkgs = (import (fetchTarball "https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz") nixpkgsOptions);
presets = {
base = (import ./presets/base.nix);
kvm = (import ./presets/kvm.nix);
};
in {
network = {
inherit pkgs;
description = "Cryto";
};
"machine-haless-03.cryto.net" = {
system.stateVersion = "19.03";
imports = [
presets.base
presets.kvm
./hardware-configurations/machine-haless-03.nix
];
networking.firewall.allowedTCPPorts = [ 80 ];
services.nginx = {
enable = true;
virtualHosts = {
"haless-new.cryto.net" = {
# locations."/" = {
# root = "";
# };
locations."/shadow" = {
alias = ./sources/shadow-generator;
};
locations."/knex-mirror" = {
alias = ./sources/knex-mirror;
};
};
};
};
# services.phpfpm = {
# pools = {
# main = {
# listen = "/var/run/phpfpm-main.sock";
# };
# };
# };
};
}