You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

27 lines
558 B
Nix

let
nixpkgsOptions = {};
pkgs = (import (fetchTarball "https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz") nixpkgsOptions);
presets = {
base = (import ./presets/base.nix);
kvm = (import ./presets/kvm.nix);
};
in {
network = {
inherit pkgs;
description = "Cryto";
};
"machine-haless-03.cryto.net" = {
system.stateVersion = "19.03";
imports = [
presets.base
presets.kvm
./hardware-configurations/machine-haless-03.nix
];
services.nginx.enable = true;
networking.firewall.allowedTCPPorts = [ 80 ];
};
}