You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

22 lines
556 B
Nix

let
removeNewlines = (import ../lib/util/remove-newlines.nix);
presetRootSsh = (import ../lib/presets/root-ssh.nix);
in {
resources.sshKeyPairs.ssh-key = {};
osmium = {config, pkgs, ...}@args: let
presetTools = (import ../lib/presets/tools.nix) args;
in
{
deployment.targetEnv = "digitalOcean";
deployment.digitalOcean.region = "ams2";
deployment.digitalOcean.size = "512mb";
systems.osmium = {
applications.pastebin-stream = {
hostname = "pastebin-stream-dev.cryto.net";
};
};
} // presetRootSsh // presetTools;
}