You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
24 lines
439 B
Nix
24 lines
439 B
Nix
listenAddress: {
|
|
systemd.extraConfig = ''
|
|
DefaultCPUAccounting=yes
|
|
DefaultIOAccounting=yes
|
|
DefaultIPAccounting=yes
|
|
DefaultBlockIOAccounting=yes
|
|
DefaultMemoryAccounting=yes
|
|
DefaultTasksAccounting=yes
|
|
'';
|
|
|
|
services.cadvisor = {
|
|
enable = true;
|
|
port = 9333;
|
|
listenAddress = listenAddress;
|
|
storageDriver = "stdout";
|
|
};
|
|
|
|
virtualisation.docker.enable = false;
|
|
|
|
networking.firewall.allowedTCPPorts = [
|
|
/* 9333 */
|
|
];
|
|
}
|