You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

8 lines
219 B
Nix

{ stdenv, pkgs, ... }:
{ path, storeHash, ... }:
let
derivationName = baseNameOf path;
storePath = "/nix/store/${storeHash}-${derivationName}";
in
if builtins.pathExists storePath then storePath else path