You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

14 lines
398 B
Nix

packages: {config, pkgs, ...}: {
/* The following enables wpa_cli usage, and disables declarative network specification */
networking = {
wireless = {
enable = true;
userControlled.enable = true;
};
networkmanager.enable = pkgs.lib.mkForce false;
};
environment.etc."wpa_supplicant.conf".text = "ctrl_interface=/run/wpa_supplicant";
}