Browse Source

Update supported platforms

- Drop support for Node.js v4
- Add support for Node.js v10
- Drop support for IE < 11
master
Futago-za Ryuu 3 years ago
parent
commit
3cedf4439d
  1. 2
      .babelrc
  2. 2
      .eslintrc.js
  3. 2
      .travis.yml
  4. 6
      docs/notes/compatibility.md
  5. 2
      package.json

2
.babelrc

@ -7,7 +7,7 @@
{
"modules": false,
"targets": {
"ie": 9
"ie": 11
}
}
]

2
.eslintrc.js

@ -2,7 +2,7 @@
module.exports = {
"extends": "futagozaryuu/node-v4",
"extends": "futagozaryuu/node-v6",
"root": true,
"rules": {

2
.travis.yml

@ -3,9 +3,9 @@ sudo: false
language: node_js
node_js:
- "4"
- "6"
- "8"
- "10"
after_success:
- yarn coverage

6
docs/notes/compatibility.md

@ -2,9 +2,9 @@
Both the parser generator and generated parsers should run well in the following environments:
* Node.js 4+
* Internet Explorer 9+
* Edge
* Node.js v6+
* Internet Explorer 11
* Microsoft Edge
* Firefox
* Chrome
* Safari

2
package.json

@ -65,6 +65,6 @@
"vinyl-source-stream": "2.0.0"
},
"engines": {
"node": ">=4"
"node": ">= 6"
}
}
Loading…
Cancel
Save