Browse Source

Require Node.js >= 0.10.0

Travis CI builds with Node.js 0.8.x started to fail:

  https://travis-ci.org/dmajda/pegjs/jobs/26691570

Rather than investigating what's wrong I decided to stop supporting Node
0.8.x. Node.js 0.10.x is here for over a year, which should be enough
time for everyone to upgrade in the fast-paced Node.js world.
redux
David Majda 8 years ago
parent
commit
4a3b9cbb8d
  1. 1
      .travis.yml
  2. 2
      README.md
  3. 2
      package.json

1
.travis.yml

@ -1,4 +1,3 @@
language: node_js
node_js:
- 0.8
- 0.10

2
README.md

@ -416,7 +416,7 @@ Compatibility
Both the parser generator and generated parsers should run well in the following
environments:
* Node.js 0.8.0+
* Node.js 0.10.0+
* IE 8+
* Firefox
* Chrome

2
package.json

@ -51,6 +51,6 @@
"jshint": "= 2.3.0"
},
"engines": {
"node": ">= 0.8"
"node": ">= 0.10.0"
}
}
Loading…
Cancel
Save