Browse Source

Updated dependencies

master
Futago-za Ryuu 3 years ago
parent
commit
c65e9dd95f
  1. 10
      package.json
  2. 89
      yarn.lock

10
package.json

@ -17,7 +17,7 @@
"coverage": "nyc report --reporter=text-lcov | coveralls"
},
"dependencies": {
"@babel/core": "7.0.0",
"@babel/core": "7.0.1",
"@babel/preset-env": "7.0.0",
"body-parser": "1.18.3",
"chai": "4.1.2",
@ -25,10 +25,10 @@
"ejs": "2.6.1",
"express": "4.16.3",
"express-layout": "0.1.0",
"morgan": "1.9.0",
"morgan": "1.9.1",
"pretty-ms": "3.2.0",
"sinon": "6.2.0",
"rollup": "0.65.2",
"sinon": "6.3.3",
"rollup": "0.66.0",
"rollup-plugin-babel": "4.0.3",
"rollup-plugin-commonjs": "9.1.6",
"rollup-plugin-multi-entry": "2.0.2",
@ -46,7 +46,7 @@
"gulp-mocha": "6.0.0",
"nyc": "13.0.1",
"pump": "3.0.0",
"rollup-plugin-terser": "2.0.2"
"rollup-plugin-terser": "3.0.0"
},
"engines": {
"node": ">= 6"

89
yarn.lock

@ -20,9 +20,9 @@
dependencies:
"@babel/highlight" "^7.0.0"
"@babel/core@7.0.0":
version "7.0.0"
resolved "https://registry.yarnpkg.com/@babel/core/-/core-7.0.0.tgz#0cb0c0fd2e78a0a2bec97698f549ae9ce0b99515"
"@babel/core@7.0.1":
version "7.0.1"
resolved "https://registry.yarnpkg.com/@babel/core/-/core-7.0.1.tgz#406658caed0e9686fa4feb5c2f3cefb6161c0f41"
dependencies:
"@babel/code-frame" "^7.0.0"
"@babel/generator" "^7.0.0"
@ -680,15 +680,23 @@
dependencies:
type-detect "4.0.8"
"@sinonjs/formatio@^2.0.0":
version "2.0.0"
resolved "https://registry.yarnpkg.com/@sinonjs/formatio/-/formatio-2.0.0.tgz#84db7e9eb5531df18a8c5e0bfb6e449e55e654b2"
"@sinonjs/formatio@3.0.0", "@sinonjs/formatio@^3.0.0":
version "3.0.0"
resolved "https://registry.yarnpkg.com/@sinonjs/formatio/-/formatio-3.0.0.tgz#9d282d81030a03a03fa0c5ce31fd8786a4da311a"
dependencies:
samsam "1.3.0"
"@sinonjs/samsam" "2.1.0"
"@sinonjs/samsam@^2.0.0":
version "2.0.0"
resolved "https://registry.yarnpkg.com/@sinonjs/samsam/-/samsam-2.0.0.tgz#9163742ac35c12d3602dece74317643b35db6a80"
"@sinonjs/samsam@2.1.0":
version "2.1.0"
resolved "https://registry.yarnpkg.com/@sinonjs/samsam/-/samsam-2.1.0.tgz#b8b8f5b819605bd63601a6ede459156880f38ea3"
dependencies:
array-from "^2.1.1"
"@sinonjs/samsam@^2.1.0":
version "2.1.1"
resolved "https://registry.yarnpkg.com/@sinonjs/samsam/-/samsam-2.1.1.tgz#f352621c24c9e9ab2ed293a7655e8d46bfd64c16"
dependencies:
array-from "^2.1.1"
"@types/estree@0.0.39":
version "0.0.39"
@ -853,6 +861,10 @@ array-flatten@1.1.1:
version "1.1.1"
resolved "https://registry.yarnpkg.com/array-flatten/-/array-flatten-1.1.1.tgz#9a5f699051b1e7073328f2a008968b64ea2955d2"
array-from@^2.1.1:
version "2.1.1"
resolved "https://registry.yarnpkg.com/array-from/-/array-from-2.1.1.tgz#cfe9d8c26628b9dc5aecc62a9f5d8f1f352c1195"
array-initial@^1.0.0:
version "1.1.0"
resolved "https://registry.yarnpkg.com/array-initial/-/array-initial-1.1.0.tgz#2fa74b26739371c3947bd7a7adc73be334b3d795"
@ -3130,10 +3142,14 @@ log-driver@^1.2.7:
version "1.2.7"
resolved "https://registry.yarnpkg.com/log-driver/-/log-driver-1.2.7.tgz#63b95021f0702fedfa2c9bb0a24e7797d71871d8"
lolex@^2.3.2, lolex@^2.7.2:
lolex@^2.3.2:
version "2.7.2"
resolved "https://registry.yarnpkg.com/lolex/-/lolex-2.7.2.tgz#ff11decab010cf37d6194ab44bb57970b5f4966b"
lolex@^2.7.4:
version "2.7.4"
resolved "https://registry.yarnpkg.com/lolex/-/lolex-2.7.4.tgz#6514de2c3291e9d6f09d49ddce4a95f7d4d5a93f"
loose-envify@^1.0.0:
version "1.4.0"
resolved "https://registry.yarnpkg.com/loose-envify/-/loose-envify-1.4.0.tgz#71ee51fa7be4caec1a63839f7e682d8132d30caf"
@ -3356,13 +3372,13 @@ mocha@^5.2.0:
mkdirp "0.5.1"
supports-color "5.4.0"
morgan@1.9.0:
version "1.9.0"
resolved "https://registry.yarnpkg.com/morgan/-/morgan-1.9.0.tgz#d01fa6c65859b76fcf31b3cb53a3821a311d8051"
morgan@1.9.1:
version "1.9.1"
resolved "https://registry.yarnpkg.com/morgan/-/morgan-1.9.1.tgz#0a8d16734a1d9afbc824b99df87e738e58e2da59"
dependencies:
basic-auth "~2.0.0"
debug "2.6.9"
depd "~1.1.1"
depd "~1.1.2"
on-finished "~2.3.0"
on-headers "~1.0.1"
@ -3422,11 +3438,11 @@ nice-try@^1.0.4:
version "1.0.5"
resolved "https://registry.yarnpkg.com/nice-try/-/nice-try-1.0.5.tgz#a3378a7696ce7d223e88fc9b764bd7ef1089e366"
nise@^1.4.4:
version "1.4.4"
resolved "https://registry.yarnpkg.com/nise/-/nise-1.4.4.tgz#b8d9dd35334c99e514b75e46fcc38e358caecdd0"
nise@^1.4.5:
version "1.4.5"
resolved "https://registry.yarnpkg.com/nise/-/nise-1.4.5.tgz#979a97a19c48d627bb53703726ae8d53ce8d4b3e"
dependencies:
"@sinonjs/formatio" "^2.0.0"
"@sinonjs/formatio" "3.0.0"
just-extend "^3.0.0"
lolex "^2.3.2"
path-to-regexp "^1.7.0"
@ -4312,12 +4328,13 @@ rollup-plugin-node-resolve@3.4.0:
is-module "^1.0.0"
resolve "^1.1.6"
rollup-plugin-terser@2.0.2:
version "2.0.2"
resolved "https://registry.yarnpkg.com/rollup-plugin-terser/-/rollup-plugin-terser-2.0.2.tgz#1b59d67c80fc0d499cdc29a6991944b2d671ea03"
rollup-plugin-terser@3.0.0:
version "3.0.0"
resolved "https://registry.yarnpkg.com/rollup-plugin-terser/-/rollup-plugin-terser-3.0.0.tgz#045bd7cf625ee1affcfe6971dab6fffe6fb48c65"
dependencies:
"@babel/code-frame" "^7.0.0"
jest-worker "^23.2.0"
serialize-javascript "^1.5.0"
terser "^3.8.2"
rollup-pluginutils@^2.0.1, rollup-pluginutils@^2.3.0, rollup-pluginutils@^2.3.1:
@ -4327,9 +4344,9 @@ rollup-pluginutils@^2.0.1, rollup-pluginutils@^2.3.0, rollup-pluginutils@^2.3.1:
estree-walker "^0.5.2"
micromatch "^2.3.11"
rollup@0.65.2:
version "0.65.2"
resolved "https://registry.yarnpkg.com/rollup/-/rollup-0.65.2.tgz#e1532e3c1a2e102c89d99289a184fcbbc7cd4b4a"
rollup@0.66.0:
version "0.66.0"
resolved "https://registry.yarnpkg.com/rollup/-/rollup-0.66.0.tgz#697acc008f4b613695b17222c7626affddf4a506"
dependencies:
"@types/estree" "0.0.39"
"@types/node" "*"
@ -4364,10 +4381,6 @@ safe-regex@^1.1.0:
version "2.1.2"
resolved "https://registry.yarnpkg.com/safer-buffer/-/safer-buffer-2.1.2.tgz#44fa161b0187b9549dd84bb91802f9bd8385cd6a"
samsam@1.3.0:
version "1.3.0"
resolved "https://registry.yarnpkg.com/samsam/-/samsam-1.3.0.tgz#8d1d9350e25622da30de3e44ba692b5221ab7c50"
sax@^1.2.4:
version "1.2.4"
resolved "https://registry.yarnpkg.com/sax/-/sax-1.2.4.tgz#2816234e2378bddc4e5354fab5caa895df7100d9"
@ -4404,6 +4417,10 @@ send@0.16.2:
range-parser "~1.2.0"
statuses "~1.4.0"
serialize-javascript@^1.5.0:
version "1.5.0"
resolved "https://registry.yarnpkg.com/serialize-javascript/-/serialize-javascript-1.5.0.tgz#1aa336162c88a890ddad5384baebc93a655161fe"
serve-static@1.13.2:
version "1.13.2"
resolved "https://registry.yarnpkg.com/serve-static/-/serve-static-1.13.2.tgz#095e8472fd5b46237db50ce486a43f4b86c6cec1"
@ -4467,17 +4484,17 @@ signal-exit@^3.0.0, signal-exit@^3.0.2:
version "3.0.2"
resolved "https://registry.yarnpkg.com/signal-exit/-/signal-exit-3.0.2.tgz#b5fdc08f1287ea1178628e415e25132b73646c6d"
sinon@6.2.0:
version "6.2.0"
resolved "https://registry.yarnpkg.com/sinon/-/sinon-6.2.0.tgz#ec95af3a88aeb451f0275f14213e6e9f066879e2"
sinon@6.3.3:
version "6.3.3"
resolved "https://registry.yarnpkg.com/sinon/-/sinon-6.3.3.tgz#c3a55b7046174c139e87a3c94c922cbf4323a4e7"
dependencies:
"@sinonjs/commons" "^1.0.2"
"@sinonjs/formatio" "^2.0.0"
"@sinonjs/samsam" "^2.0.0"
"@sinonjs/formatio" "^3.0.0"
"@sinonjs/samsam" "^2.1.0"
diff "^3.5.0"
lodash.get "^4.4.2"
lolex "^2.7.2"
nise "^1.4.4"
lolex "^2.7.4"
nise "^1.4.5"
supports-color "^5.5.0"
type-detect "^4.0.8"

Loading…
Cancel
Save